Author Topic: Live tracking error in 2.98  (Read 1060 times)

tdcarter

  • Sr. Member
  • ****
  • Posts: 80
    • View Profile
Live tracking error in 2.98
« on: November 03, 2006, 07:02:17 PM »
Hi guys,
Out doing some running around the eastern mid-west and thought I'd play with the laptop/gps while someone else drove.

Well the speed on the live tracking window reports we were doing 120 mi ph while we were behind a state trooper. His crown vic might have been able to maintain that speed... but our rental Sebring is probably not capable of that for a very long period.

Actually... the speedometer said we were doing in the upper 70's/lower 80's, and that was confirmed on the display of my Edge 305. But TF had a whole different set of numbers. Also of note... no speed or times were recorded in the tracklog when I saved the track from the live tracking.

On another note.. maybe similar, maybe not. I tried using this feature about a year ago with my 201 and got similar results. I atributed it to the fact that I had to use a USB-serial adapter between the 201 and my laptop.

Yes? No?

Ohhhh... I also tried running my Edge through Franson GPS gate and then using the serial input to TF. No joy. I saved the logs if it'll help. Mostly the signifigant message was:
-------------------------------------
Initializing Com2 at 9600 baud.
NT: The operation completed successfully.

GetLastError = 0
checksum error coming from GPS, retrying, checksum/pchecksum 171 - 50
checksum error coming from GPS, retrying, checksum/pchecksum 220 - 50
checksum error coming from GPS, retrying, checksum/pchecksum 11 - 10....etc....
-------------------------------------

Okay it might be two seperate issues. If so, let me know and we'll track it seperatly... or not at all if I seem to be the lone wolf here.

TC

Krein

  • Administrator
  • Sr. Member
  • *****
  • Posts: 1203
  • TopoFusion Author
    • View Profile
    • http://www.topofusion.com/diary
Live tracking error in 2.98
« Reply #1 on: November 07, 2006, 05:12:49 PM »
Actually your data was transfered to the highway patrol and you'll be getting the ticket in the mail...

No, the speed issue is a bug that was reported a while ago but got lost somehow.  I believe I just fixed it, but won't be able to check it for a while.

As for GPS gate, not sure anyone has tried using that software before.  Incorrect checksum seems like it's their problem not ours, what other programs does it *work* on?

I assume you're splitting a GPS feed.  Using the Garmin protocol?

Thanks for the feedback, as always.

tdcarter

  • Sr. Member
  • ****
  • Posts: 80
    • View Profile
Live tracking error in 2.98
« Reply #2 on: November 07, 2006, 07:53:25 PM »
Hi Scott,
Yep, nope, and others...

Not splitting the feed. I have it set for just a single com port. I have successfully used it for Garmin Nroute, DeLorme Street atlas (that database is scary), and MS Streets and trips.

One of them gets a little goofy when you use the Edge, it wasn't reporting the number of satellites correctly. But it did work. I don't really remember wich got goofy as I mostly use Streets and trips.. not nearly as bloated a program as the others. (MS not bloated.. did I say that?) '<img'>

The Fanson software may not be perfect....but I do like being able to just drag the Edge along and use it as a USB GPS for trips. Hmmm... I need to see if there are any patches for the program I guess.

As always guys.. love the program and the changes.. keep up the good work. I'm getting ready for a ride from Key Largo to Key West... so I'll be sure to track it all and use the updated photo-fusion soon.

TC